Creating the administrative site

Creating a customer-facing site is important and not too difficult, but what do you do to
add records to the database? For example, when there is a price increase, how do you
change that? If a band's album stops selling, what do you do to take it out of your
catalog? If you were doing your site as static pages, you could hire a production artist, or
modify all the pages that use that information yourself every time the information
changes.

Neither is a good option.

What you want to do is create a way to access the data on your site from behind your
firewall that accesses the same database. Or, you need to create a private password-
protected part of the site that you can use to administer the data through a browser. Since
creating a password protected site is beyond the scope of what you are going to learn
here, you are going to create a new set of pages in the same site that will allow you to
change the data in the database.

In the real world, you would never externally publish pages that would allow someone to

administer the site. This example is for you to learn how to make pages to edit.

Creating the admincatalog page

Since you need to be able to see the data much the same way as the end user of the site, a

great place to start your admin site is to copy the catalog.php page and save it as

admincatalog.php.

1. Make sure you are working on the new admincatalog.php page.

2. Put your cursor in the price column, and right click to get the context menu.

3. From the context menu, select Table > Insert Rows or Columns, and insert one
column after the current column.

4. Place your cursor in the last cell of the second row after the price for the first album.
Type "edit".

5. Select the word "edit" that you just added in the table. In the Property inspector, click
the folder icon to the right of the Link drop down
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6. Inthe File Name of the Link dialog box, type "adminedit.php". You are going to
create that file in a minute, but it does not exist now.

7. Click the Parameters button, type "AlbumID" in the name, tab to the value field.
Instead of typing in a value, click the lightning bolt icon and select the "AlbumID" in
the Catalog Recordset that comes up.

Here, you are setting the link to pass the AlbumID as a URL variable to the
adminedit.php page. There will be a Recordset on that page to catch the AlbumID
and show only the data that matches that record.

8. Click OK to set the link.
9. Save your page.

Creating the edit record page

Now that you have the admincatalog.php built, you need to create the adminedit.php
page.

Create a new page, and apply the recordstore_template to the page.

Save the page as adminedit.php.

Insert a Recordset from the Bindings panel. Select the Advanced dialog.

Either type the below SQL statement, or use the interface to create the following
Recordset (It is the same as the one you entered on the detail page):

el ol

SELECT *

FROM album, artist

WHERE album.ArtistID = artist.ArtistID
AND AlbumlID = colname

This selects all the records from the Artist and the Album tables joined on the
ArtistID column. This also sets a requirement for the AlbumID to equal the the
AlbumID being passed in from the catalog.php.

This Recordset selects all the data from the Album and Avrtist tables. It joins the
two tables on the ArtistID field. What is new here is that there is an addition of
one more condition to the WHERE statement that tells the database to only find
records where the value of the AlboumID field in the Album table is equal to the
value passed in from the URL that you just added to the admincatalog.php file.

5. Click on the "+" button next to Parameters. You are going to set a single line of PHP
that tells the query to get the value of the AlbumID that was passed to the page from
the catalog.php page.

Set that up by adding a new parameter called colname with a default of 1 and a

Run-time Value of
SHTTP_GET_VARS|['AlbumID’']
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This Recordset selects all the data from two tables, Album and Avrtist. It joins the
two tables on the ArtistID field. What is new here is that there is an addition of
one more condition to the WHERE statement that tells the database to only find
records where the value of the AloumID field in the Album table is the same as
the value passed in from the URL that you just added to the admincatalog.php

file.

6. Name the Recordset"AdminEditRecordset" and click OK.

7. Insert a second Recordset. Call it ArtistRecordset and add the following SQL

statement:
SELECT *
FROM Artist
You are going to use this to populate a pop up menu.

8. Place your cursor in the Main Area Content Area, delete the place holder text, and
select Insert > Application Objects > Record Update Form. Fill out the Record

Update Form dialog box with the following choices:

Record Update Form

Conneckion: |cannl b
Table to update: | album w
Select record from: | AdminEditRecordset W
Unique key column: | AlbumID w Mumeric
After updating, go to: | admincatalog.php
Form Figlds: iJ :J :J IJ
Calurnn [Label | Display as |submit &s |
Albumbame Albumblame: Texk Field Texk
ArtistID ArtistIn: Menu Murmeric
alburnPrice AlbumPrice: Text Field Mumeric
AlbumnMotes AlbumMotes: Text Fizld Texk
0 | P,y S P [0 | PR, iy P N | To. L Lol L M

Label; | ArtistID:

Display as: | Meanu “ | Submit as: | Mumeric "

Menu Properties, .,

B

9. Select Album from the Table to Update

10. Select AdminEditRecordset from the Select Record From pop up menu.
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11.

12.

13.

14.

15.
16.

Menu Properties

Select the Unique Key Column to be AlbumID, and insert as an integer by checking
the Numeric checkbox.

Set the After Updating, Go To to admincatalog.php, so that you can see the changes
you made.

Below the line, delete the AlbumAuvailable field and you want to remove the
AlbumID field. You don't want to insert the AlbumID because that is automatically
generated by the database. Remove the AlbumAvaliable field, since we are not using
that in this tutorial.

Select the ArtistID form field in the Form Field area of the dialog box. You are going
to change this so that it displays as a menu and not as a text area.

Select Menu from the Display As: pop up menu.

Click the Menu Properties... button.

Populate Menu Ttems: © Manually

* From Database Cancel |

Recordset I.ﬁ.rtistRecnrdset j Help |
Get Labels From: I.ﬁ.rtistGrnupName j
Gek Walues Frorm: I.ﬁ.rtistID j

Select Yalue Equal To: | «<¢php echo $row_AdminEditRecordset] ArtistID' ﬂ

17.

18.
19.
20.

21.
22.
23.

Select the From Database radio button to populate the menu items from a database
and select the ArtistRecordset as the Recordset. You want to select that one, because
you want to get all the names for all the bands in the pop up menu not just the name
of the selected band... It would be useless to have a pop up with only one choice.
Set Get Labels From to ArtistGroupName.

Set Get Values From to ArtistID.

Set Select VValue Equal To field to ArtistlD, which you do by clicking the small
lightning bolt at the end of the field.

Click OK.

Click OK again to OK the Record Update Form.

Save your file.

Check your work:

- Start your browser (Internet Explorer)
- Visit your admincatalog.php:
Example: http://www.maxtips.com/dw/3/admincatalog.php
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Add delete link to admincatalog page : Thisis how to delete a record in
your database by creating !
Open admincatalog.php backend interface for your clients.
Leave your cursor in the edit column ~ *TTTTTTTTToToomoosoooooomomomoeoes

Right-click in the edit column, then choose Table > Insert Rows or Columns

wn =

Insert Rows or Columns

Insert: () Rows o

Mumber of calumns: DI

where: () Before current Column

Cancel

|

(%) After current Column Help

In the 2" row of the new column, type: delete
Highlight delete and go to the Properties Panel
In the Link box type: admindelete.php

. Click the yellow Folder icon

Select file name fram: l@l File spstem Site Root

() Data sources

ISR A

\‘

Look jn: |l.§ dreamn?2 v| y 3 = [@-

ICh _mmServerScripts L@a|:In'|inc.ilt.5|h:|g| with add. php
I _niokes I'@au:lmincalzalu:ug.|:I'||:u
[Chassets I'@Eu:lmincataI|:|g|_|:|r|;|.|:|h|:|

|1 Connections I'@En:lmineu:lit.|:|h|:|

ICimages I'@Enll:uumchalzail.|:||'||:u

I Templates L@catalu:u;|.|:nh|:|
I'ﬁau:lminau:lu:i.|:|h|:| I'ﬁcIeIete_reu:u:uru:I.|:|h|:|

File name: |adminde|ele.php | [ ok ]

Files of type: | &l Files (%] v| | Cancel |

JRL: | admindelete. php | [ Parameters. ..

Felative to: admincatalog. php

Change default Link Relative To in the site definition.

Click Parameters button

8. From the Recordset (catalog), choose AlbumID
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Field: (5B Recordset (Latesthews) A [L]
=] Recordset (catalag)
e 4F 0 ArtistID
- 47 AlbumPrice
w4 AlbumMokes
g2 AlbumCatalogMumber  —
w52 Albumivailable
- 4% AlbumCoverURL
w43 AlbumCover Thumbnailld
] AukickTM Y
¢ &
Format: |N0ne S |
Code: |<?php echo $row_catalog[albuml D'); 7> |

9. Click OK.

10. Click File, Save.

11. Uplaod admincatalog.php
12. Click File, Close.

Create admindelete.php Page

Create a new file from the template

File, Save As

Type: admindelete.php

Click in the Main Area Content, and delete the placeholder text .

i ol A

On the right go to the Server behaviors, and choose Delete Record
If you’re using CS3, from the insert bar, click the Data tab,
then click Delete Record button. Fill out the form with the following choices.

Delete Record

First check if variable is defined: |Primary ke walue

Conneckion: |c0nn1

Table: |a||:|um

Primary key calumn: |.¢\Il:u.|rnID

¥ | Murmeric

Primary key value; |URL Parameter

~ | AlbumIp

After deleting, go to: | catalog.php

HBru:uwse... ]

3
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Click OK.
Click File, Save.

O No O

Click File, Close.

Upload admindelete.php

Let's delete arecord:

1. Start your browser

2. Go to your admincatalog.php

Example:

http://www.maxtips.com/dw/3/admincatalog.php

3. Go to the last record
Album: The Road less Traveled

4. Click Delete to delete this record

5. Your catalog.php appears without this record.

Job well done.

RECORDO store

Yellow Lotus Experimental 1&
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This is how to add a record in

Create the Insert Record Page
your database by creating !

backend interface for your clients.

___________________________________

Part 1: Add a button to AdminCatalog.php

Open the admincatalog.php page if it is not already open.
Select the contents of the Sidebar Content and delete it.

From the Insert bar, Common Tab, click the image button
Choose assets/b_addalbum.gif, and click OK

Go to the Properties Panel, we need to make two changes

In the link box type: adminadd.php (this file doesn’t exist yet)
In the border box, type 0 (zero)

Click File, Save.

© ® N o g bk~ 0w DN

Click Put to upload this file to the server.
10. Click File, Close.

Part 2: Create 2 recordsets

1. Create a new page from your template and save it as adminadd.php

no

Go to the Binding Panel and click + to Insert a new Recordset .

3. Select the Advanced dialog:

Name: AlbumRecordset
Connection: connl

SQL : SELECT * FROM album

Click Ok.

4. Go to the Binding Panel again and click + to Insert another Recordset .
Select the Advanced dialog:

o

Name: ArtistRecordset
Connection: connl
SQL : SELECT * FROM artist

Click Ok.
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Part 3: Create Add Page

6. Click in the Main Area Content, and delete the placeholder text from the main
content area.
7. Select Insert > Application Objects > Record Insertion Wizard Form.

If you’re using CS3, from the insert bar, click the Data tab, then click Insert Record
button > Insert Record Wizard.

Fill out the form with the following choices.

Record Insertion Form ﬁ
|
Connection: [connl hd
Table: |album W
After inserting, go to: | admincatalog, php
Form Fields: iJ :J :J IJ
Column [Label |Display as [ submit &s | A
AlburMamme AlburmMame: Text field Text
ArkiskID ArtistID: Menu MNumeric
AlbumPrice alburmPrice: Texk field Mumeric
AlbumMotes AlburmMotes: Text field Text
AlbumCatalo... AlbumiCatalogh. .. Text Field Mumeric
Albnimavailahls  albimassilablse Tevt Fisld Rliirnarie W
Label: | ArtistID:
Display as: |Menu “ | Submit as; | Mumetic v

g

Set the After Inserting Go To destination to admincatalog.php
9. Inthe Form fields area, leave all of the form fields except AlbumID, which the

database is going to assign automatically and the AlbumAuvailable, which we are not
using in this tutorial.

10. Select the ArtistID form field, set it to Menu, and click the Menu Properties... button.

11. Set Populate From to From Database and select the ArtistRecordset.

12. Set Get Labels From to ArtistGroupName.

13. Set Get Values From to ArtistID.

14. Leave the Select Value Equal To empty because there is no data being handed to the
form to display.

14. Click OK.
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Menu Properties

Populate menu items: ) Marially

® From database

Recordset; | ArkistRecordset w |

Get labels from: F'.r'ti::tGr'n:nupr'-JarnEe

Get values from: | ArkistID w |

Select walue equal to: | |ﬂ

k.

Cancel

III X

Help

15. Click OK again to OK the Record Insertion Form.
16. Click File, Save.

17. Upload your file (PUT)

18. Start your browser

19. Type the url to see your admincatalog.php

Example: http://www.maxtips.com/dw/3/admincatalog.php

admincatalog.php
v
adminedit.php admindelete.php adminadd.php
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Add A New Record:

1. Start your browser

2. Go to your admincatalog.php
Example: http://www.maxtips.com/dw/3/admincatalog.php

ed

Click add record
4. Fill out the insert from as:
AlburnMarne: | 1 he Foad less Trawveled
artistID: | Jaenus w
AlburnPrice: |55
alburnNotes: Launching a dream
AlbumCatalogdurber: 333
Alburnavailable: |2
alburncoverUrL: @ssets/bands/JAENLUS_cowverjpg

alburncoverThumbnailurL: fSetsfbands/JAEMNUS_thumbnail jpg

[ Insert record ]

AlbumCoverURL: assets/bands/JAENUS _cover.jpg
AlbumCoverThumbnailURL: assets/bands/JAENUS _thumbnail.jpg

* After typing all the data, click the Insert record button.

Admincatalog.php will appear with your new record.

Congratulations.
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